2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets by Bill Allombert 2001
8 # Uncomment this to turn on verbose mode.
11 # This has to be exported to make some magic below work.
14 PYVERS := $(shell pyversions -vr)
15 PY3VERS := $(shell py3versions -vr)
17 PKGROOT=$(CURDIR)/debian/python-pyxattr
18 DBGROOT=$(CURDIR)/debian/python-pyxattr-dbg
19 PKG3ROOT=$(CURDIR)/debian/python3-pyxattr
20 DBG3ROOT=$(CURDIR)/debian/python3-pyxattr-dbg
22 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
23 DPKG_EXPORT_BUILDFLAGS = 1
24 include /usr/share/dpkg/buildflags.mk
26 build: build-arch build-indep
29 build-arch: $(PYVERS:%=build-python%) $(PY3VERS:%=build-python%)
34 python$* setup.py build
35 python$*-dbg setup.py build
44 rm -f build-indep build-arch
46 rm -f $(PYVERS:%=build-python%)
47 rm -f $(PY3VERS:%=build-python%)
48 rm -rf pxattr.egg-info
51 install: build $(PYVERS:%=install-python%) $(PY3VERS:%=install-python%)
52 find $(DBGROOT) ! -type d ! -name '*_d.so' | xargs rm -f
53 find $(DBGROOT) -depth -empty -print0 | xargs -r0 rmdir
56 python2$* setup.py install --root $(PKGROOT) --install-layout=deb
57 python2$*-dbg setup.py install --root $(DBGROOT) --install-layout=deb
60 python3$* setup.py install --root $(PKG3ROOT) --install-layout=deb
61 python3$*-dbg setup.py install --root $(DBG3ROOT) --install-layout=deb
63 # Build architecture-dependent files here.
64 binary-arch: build install
70 dh_strip -ppython-pyxattr --dbg-package=python-pyxattr-dbg
71 dh_strip -ppython3-pyxattr --dbg-package=python3-pyxattr-dbg
72 rm -rf $(DBGROOT)/usr/share/doc/python-pyxattr-dbg
73 ln -s python-pyxattr $(DBGROOT)/usr/share/doc/python-pyxattr-dbg
74 rm -rf $(DBG3ROOT)/usr/share/doc/python3-pyxattr-dbg
75 ln -s python3-pyxattr $(DBG3ROOT)/usr/share/doc/python3-pyxattr-dbg
86 # Build architecture independant packages here.
87 binary-indep: build install
90 binary: binary-arch binary-indep
91 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure