2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets by Bill Allombert 2001
8 # Uncomment this to turn on verbose mode.
11 # This has to be exported to make some magic below work.
14 PYVERS := $(shell pyversions -vr)
16 build: $(PYVERS:%=build-python%) build-indep
20 python$* setup.py build
24 ./setup.py build_ext -i && epydoc --config epydoc.conf
30 rm -f build-arch-stamp build-indep #CONFIGURE-STAMP#
34 install: build $(PYVERS:%=install-python%)
37 python$* setup.py install --root $(CURDIR)/debian/python-pyxattr
39 # Build architecture-dependent files here.
40 binary-arch: build install
55 # Build architecture independant packages here.
56 binary-indep: build install
59 binary: binary-arch binary-indep
60 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure