]> git.k1024.org Git - debian-pyxattr.git/blob - debian/rules
Add quilt support to the package
[debian-pyxattr.git] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 #
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets  by Bill Allombert 2001
7
8 # Uncomment this to turn on verbose mode.
9 #export DH_VERBOSE=1
10
11 include /usr/share/quilt/quilt.make
12
13 # This has to be exported to make some magic below work.
14 export DH_OPTIONS
15
16 PYVERS := $(shell pyversions -vr)
17
18 build: $(PYVERS:%=build-python%) build-indep
19         touch $@
20
21 build-python%: $(QUILT_STAMPFN)
22         python$* setup.py build
23         touch $@
24
25 build-indep:
26         ./setup.py build_ext -i && epydoc --config epydoc.conf
27         touch $@
28
29 clean: unpatch
30         dh_testdir
31         dh_testroot
32         rm -f build-arch-stamp build-indep #CONFIGURE-STAMP#
33         rm -rf build html
34         rm -f xattr.so
35         rm -f $(PYVERS:%=build-python%)
36         dh_clean
37
38 install: build $(PYVERS:%=install-python%)
39
40 install-python%:
41         python$* setup.py install --root $(CURDIR)/debian/python-pyxattr
42
43 # Build architecture-dependent files here.
44 binary-arch: build install
45         dh_testdir
46         dh_testroot
47         dh_installchangelogs
48         dh_installdocs
49         dh_strip
50         dh_compress -X.js
51         dh_fixperms
52         dh_pysupport
53         dh_installdeb
54         dh_shlibdeps
55         dh_gencontrol
56         dh_md5sums
57         dh_builddeb
58
59 # Build architecture independant packages here.
60 binary-indep: build install
61 # Nothing to do
62
63 binary: binary-arch binary-indep
64 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure