2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets by Bill Allombert 2001
8 # Uncomment this to turn on verbose mode.
11 include /usr/share/quilt/quilt.make
13 # This has to be exported to make some magic below work.
16 PYVERS := $(shell pyversions -vr)
18 build: $(PYVERS:%=build-python%) build-indep
21 build-python%: $(QUILT_STAMPFN)
22 python$* setup.py build
26 ./setup.py build_ext -i && epydoc --config epydoc.conf
32 rm -f build-arch-stamp build-indep #CONFIGURE-STAMP#
35 rm -f $(PYVERS:%=build-python%)
38 install: build $(PYVERS:%=install-python%)
41 python$* setup.py install --root $(CURDIR)/debian/python-pyxattr
43 # Build architecture-dependent files here.
44 binary-arch: build install
59 # Build architecture independant packages here.
60 binary-indep: build install
63 binary: binary-arch binary-indep
64 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure