]> git.k1024.org Git - debian-pyxattr.git/blob - debian/rules
Fix installation of documentation
[debian-pyxattr.git] / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 # This has to be exported to make some magic below work.
7 export DH_OPTIONS
8
9 export PYBUILD_NAME = pyxattr
10
11 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
12 DPKG_EXPORT_BUILDFLAGS = 1
13 include /usr/share/dpkg/buildflags.mk
14
15 %:
16         dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
17
18 override_dh_auto_build:
19         dh_auto_build
20         PYTHONPATH=. http_proxy='127.0.0.1:9' make doc
21
22 override_dh_strip:
23         dh_strip -ppython-pyxattr --dbgsym-migration='python-pyxattr-dbg (<< 0.5.6-1~)'
24         dh_strip -ppython3-pyxattr --dbgsym-migration='python3-pyxattr-dbg (<< 0.5.6-1~)'
25
26 override_dh_auto_test:
27         @echo "Tests need an xattr-enabled filesystem, not running by default"
28
29 override_dh_installdocs:
30         dh_installdocs -A README.rst
31
32 override_dh_installchangelogs:
33         dh_installchangelogs -A NEWS