#!/usr/bin/make -f

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

export PYBUILD_NAME = pyxattr

export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk

%:
	dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_build:
	dh_auto_build
	PYTHONPATH=. http_proxy='127.0.0.1:9' make doc

override_dh_strip:
	dh_strip -ppython-pyxattr --dbgsym-migration='python-pyxattr-dbg (<< 0.5.6-1~)'
	dh_strip -ppython3-pyxattr --dbgsym-migration='python3-pyxattr-dbg (<< 0.5.6-1~)'

override_dh_auto_test:
	@echo "Tests need an xattr-enabled filesystem, not running by default"

override_dh_installdocs:
	dh_installdocs -A README.rst

override_dh_installchangelogs:
	dh_installchangelogs -A NEWS