]> git.k1024.org Git - debian-pylibacl.git/blob - debian/tests/run-testsuite-if-acls-enabled
Drop python2 support; Closes: #938073
[debian-pylibacl.git] / debian / tests / run-testsuite-if-acls-enabled
1 #!/bin/sh
2
3 TESTFILE="$AUTOPKGTEST_TMP/foo"
4
5 touch "$TESTFILE"
6
7 if setfacl -m u:root:r "$TESTFILE"; then
8   echo "Temporary directory '$AUTOPKGTEST_TMP' has ACLs enabled, running tests"
9   export TEST_DIR="$AUTOPKGTEST_TMP"
10   echo "* testing Python 3"
11   python3 test/test_acls.py
12   echo "* testing Python 3 debug package"
13   python3-dbg test/test_acls.py
14 else
15   echo "Temporary directory '$AUTOPKGTEST_TMP' doesn't have extended attributes enabled"
16   echo "Skipping the tests :("
17 fi