Fixup autopkgtests for new upstream version
[debian-pylibacl.git] / README.md
1 # pylibacl
2
3 This is a Python 3.4+ extension module allows you to manipulate the
4 POSIX.1e Access Control Lists present in some OS/file-systems
5 combinations.
6
7 Downloads: go to <http://pylibacl.k1024.org/downloads>. Latest version
8 is 0.6.0. The source repository is either at
9 <https://git.k1024.org/pylibacl.git> or at
10 <https://github.com/iustin/pylibacl>.
11
12 For any issues, please file bugs at
13 <https://github.com/iustin/pylibacl/issues>.
14
15 [![Travis](https://img.shields.io/travis/iustin/pylibacl)](https://travis-ci.org/iustin/pylibacl)
16 [![Codecov](https://img.shields.io/codecov/c/github/iustin/pylibacl)](https://codecov.io/gh/iustin/pylibacl)
17 [![Read the Docs](https://img.shields.io/readthedocs/pylibacl)](http://pylibacl.readthedocs.io/en/latest/?badge=latest)
18 [![GitHub issues](https://img.shields.io/github/issues/iustin/pylibacl)](https://github.com/iustin/pylibacl/issues)
19 ![GitHub tag (latest by date)](https://img.shields.io/github/v/tag/iustin/pylibacl)
20 [![GitHub release (latest by date)](https://img.shields.io/github/v/release/iustin/pylibacl)](https://github.com/iustin/pylibacl/releases)
21 [![PyPI](https://img.shields.io/pypi/v/pylibacl)](https://pypi.org/project/pylibacl/)
22 ![Debian package](https://img.shields.io/debian/v/python-pylibacl)
23 ![Ubuntu package](https://img.shields.io/ubuntu/v/python-pylibacl)
24 ![GitHub Release Date](https://img.shields.io/github/release-date/iustin/pylibacl)
25 ![GitHub commits since latest release](https://img.shields.io/github/commits-since/iustin/pylibacl/latest)
26 ![GitHub last commit](https://img.shields.io/github/last-commit/iustin/pylibacl)
27
28 ## Requirements
29
30 pylibacl has been written and tested on Linux, kernel v2.4 or newer,
31 with XFS filesystems; ext2/ext3 should also work. Since release 0.4.0,
32 FreeBSD 7 also has quite good support. If any other platform
33 implements the POSIX.1e draft, pylibacl can be used. I heard that
34 Solaris does, but I can't test it.
35
36 - Python 3.4 or newer. Python 2.4+ was supported in the 0.5.x branch.
37 - Operating system:
38     - Linux, kernel v2.4 or newer, and the libacl library and
39       development packages (all modern distributions should have this,
40       under various names); also the file-systems you use must have
41       ACLs turned on, either as a compile or mount option.
42     - FreeBSD 7.0 or newer.
43 - The sphinx python module, for your python version, if building the
44   documentation.
45
46 ## FreeBSD
47
48 Note that on FreeBSD, ACLs are not enabled by default (at least on UFS
49 file systems). To enable them, run `tunefs -a enabled` on the file
50 system in question (after mounting it read-only). Then install:
51
52 - `pkg install py36-setuptools py36-sphinx`
53
54 or:
55
56 - `pkg install py37-setuptools`
57
58
59 License
60 -------
61
62 pylibacl is Copyright (C) 2002-2009, 2012, 2014, 2015 Iustin Pop.
63
64 pylibacl is free software; you can redistribute it and/or modify it under the
65 terms of the GNU Lesser General Public License as published by the Free
66 Software Foundation; either version 2.1 of the License, or (at your option) any
67 later version. See the COPYING file for the full license terms.