1 Date: Sun, 21 Jun 2009 16:37:01 -0400
2 From: Barry deFreese <bdefreese@debian.org>
3 To: Debian Bug Tracking System <submit@bugs.debian.org>
4 Subject: Bug#534123: python-pylibacl: FTBFS on Debian GNU/Hurd [Patch]
5 Reply-To: bdefreese@debian.org, 534123@bugs.debian.org
7 User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
9 Package: python-pylibacl
15 python-pylibacl currently fails to build on Debian GNU/Hurd because it
16 doesn't recognize GNU as an OS. Attached is a patch to resolve this.
24 macros.append(("HAVE_LEVEL2", None))
25 elif u_sysname == "Darwin":
26 libs.append("pthread")
27 +elif u_sysname == "GNU":
28 + macros.append(("HAVE_LINUX", None))
29 + macros.append(("HAVE_LEVEL2", None))
32 raise ValueError("I don't know your system '%s'."
33 " Please contact the author" % u_sysname)