]> git.k1024.org Git - debian-pylibacl.git/blob - debian/rules
Update copyright with the new upstream license
[debian-pylibacl.git] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 #
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets  by Bill Allombert 2001
7
8 # Uncomment this to turn on verbose mode.
9 #export DH_VERBOSE=1
10
11 # This has to be exported to make some magic below work.
12 export DH_OPTIONS
13
14 PYVERS := $(shell pyversions -vr)
15
16 build: $(PYVERS:%=build-python%) build-indep
17         touch $@
18
19 build-python%:
20         python$* setup.py build
21         touch $@
22
23 build-indep:
24         make doc
25         touch $@
26
27 clean:
28         dh_testdir
29         dh_testroot
30         rm -f build-arch-stamp build-indep #CONFIGURE-STAMP#
31         rm -rf build
32         dh_clean 
33
34 install: build $(PYVERS:%=install-python%)
35
36 install-python%:
37         python$* setup.py install --root $(CURDIR)/debian/python-pylibacl
38
39 # Build architecture-dependent files here.
40 binary-arch: build install
41         dh_testdir
42         dh_testroot
43         dh_installchangelogs
44         dh_installdocs
45         dh_strip
46         dh_compress -X.js
47         dh_fixperms
48         dh_pysupport
49         dh_installdeb
50         dh_shlibdeps
51         dh_gencontrol
52         dh_md5sums
53         dh_builddeb
54
55 # Build architecture independant packages here.
56 binary-indep: build install
57 # Nothing to do
58
59 binary: binary-arch binary-indep
60 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure