Merge commit 'upstream/0.5.0'
[debian-pylibacl.git] / PLATFORMS
1 Current supported platforms
2 ===========================
3
4 Linux 
5 -----
6
7 It needs kernel 2.4 or higher and the libacl library installed (with
8 development headers, if installing from rpm). This library is available
9 on all modern distributions.
10
11 The level of compliance is level 2 (see IMPLEMENTATION), plus some extra
12 functions; and as my development is done on Linux, I try to implement
13 these extensions when it makes sense.
14
15
16 FreeBSD
17 -------
18
19 The current tested version is 7.0. FreeBSD supports all the standards
20 functions, but 7.0-RELEASE seems to have some issues regarding the
21 acl_valid() function when the qualifier of an ACL_USER or ACL_GROUP
22 entry is the same as the current uid. By my interpretation, this should
23 be a valid ACL, but FreeBSD declares the ACL invalid. As such, some
24 unittests fail on FreeBSD.
25
26
27 Other platforms
28 ---------------
29
30 For any other platforms, volunteers are welcome - read the PORTING file.