Remove compatibility with old recommonmark versions master
authorIustin Pop <iustin@k1024.org>
Sun, 29 Nov 2020 19:50:06 +0000 (20:50 +0100)
committerIustin Pop <iustin@k1024.org>
Sun, 29 Nov 2020 19:50:06 +0000 (20:50 +0100)
It's hard trying to keep compatibility with both very old (<1.8),
old (1.8) and modern (Sphinx), while also supporting old recommonmark;
recommonmark 0.5 was released in January 2019.

So let's drop the old support and just keep support for Sphinx 1.8 and
3.0+, and more modern recommonmark.

doc/conf.py

index c48b6d7..f507883 100644 (file)
@@ -90,12 +90,6 @@ pygments_style = 'sphinx'
 
 keep_warnings = True
 
-# Note: this is still needed in Sphinx 1.8 with recommonmark 0.4.0
-# (https://github.com/readthedocs/recommonmark/issues/119):
-source_parsers = {
-   '.md': 'recommonmark.parser.CommonMarkParser',
-}
-
 # -- Options for HTML output ---------------------------------------------------
 
 # The theme to use for HTML and HTML Help pages.  See the documentation for