]> git.k1024.org Git - debian-pyxattr.git/blob - debian/patches/fix-enodata.patch
Refresh enodata patch
[debian-pyxattr.git] / debian / patches / fix-enodata.patch
1 Fix building on systems which don't have ENODATA
2
3 This patch (a modified form of the original patch from Cyril Brulebois
4 <kibi@debian.org>) fixed building on systems which don't have ENODATA
5 (e.g.  GNU/kFreeBSD). Upstream is aware of it.
6
7 Iustin Pop, <iusty@k1024.org>
8 Wed, 12 Aug 2009 21:58:36 +0200
9 --- a/xattr.c
10 +++ b/xattr.c
11 @@ -529,7 +529,11 @@
12                      }
13                      nalloc = nval;
14                      continue;
15 -                } else if(errno == ENODATA || errno == ENOATTR) {
16 +                } else if(
17 +#ifdef ENODATA
18 +                         errno == ENODATA ||
19 +#endif
20 +                         errno == ENOATTR) {
21                      /* this attribute has gone away since we queried
22                         the attribute list */
23                      missing = 1;