7 if setfattr -n user.foo -v bar "$TESTFILE"; then
8 echo "Temporary directory '$ADTTMP' has extended attributes, running tests"
9 export TEST_DIR="$ADTTMP"
10 echo "* testing Python 2"
11 python2 test/test_xattr.py
12 echo "* testing Python 2 debug package"
13 python2-dbg test/test_xattr.py
14 echo "* testing Python 3"
15 python3 test/test_xattr.py
16 echo "* testing Python 3 debug package"
17 python3-dbg test/test_xattr.py
19 echo "Temporary directory '$ADTTMP' doesn't have extended attributes enabled"
20 echo "Skipping the tests :("