1 Author: iustin@debian.org
2 Subject: Fix building on hurd and kfreebsd
3 Description: Even though both of these arches don't have proper xattr support,
4 the package previously built on them.
9 author_email = "iustin@k1024.org"
11 -if platform.system() == 'Linux':
12 +if platform.system() != 'Darwin':
13 libraries.append("attr")
15 ("_XATTR_VERSION", '"%s"' % version),
20 #if defined(__APPLE__)
21 #include <sys/xattr.h>
22 -#elif defined(__linux__)
24 #include <attr/xattr.h>
28 return fremovexattr(filedes, name, 0);
31 -#elif defined(__linux__)
33 #define _listxattr(path, list, size) listxattr(path, list, size)
34 #define _llistxattr(path, list, size) llistxattr(path, list, size)
35 #define _flistxattr(fd, list, size) flistxattr(fd, list, size)