]> git.k1024.org Git - debian-pyxattr.git/blob - debian/tests/run-testsuite-if-attrs-enabled
Set debhelper-compat version in Build-Depends.
[debian-pyxattr.git] / debian / tests / run-testsuite-if-attrs-enabled
1 #!/bin/sh
2
3 TESTFILE="$ADTTMP/foo"
4
5 touch "$TESTFILE"
6
7 if setfattr -n user.foo -v bar "$TESTFILE"; then
8   echo "Temporary directory '$ADTTMP' has extended attributes, running tests"
9   export TEST_DIR="$ADTTMP"
10   echo "* testing Python 3"
11   python3 test/test_xattr.py
12   echo "* testing Python 3 debug package"
13   python3-dbg test/test_xattr.py
14 else
15   echo "Temporary directory '$ADTTMP' doesn't have extended attributes enabled"
16   echo "Skipping the tests :("
17 fi