]> git.k1024.org Git - debian-pyxattr.git/blob - debian/rules
Bump standards version
[debian-pyxattr.git] / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 # This has to be exported to make some magic below work.
7 export DH_OPTIONS
8
9 export PYBUILD_NAME = pyxattr
10 export PYBUILD_DISABLE = test
11
12 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
13 DPKG_EXPORT_BUILDFLAGS = 1
14 include /usr/share/dpkg/buildflags.mk
15
16 %:
17         dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
18
19 # Also build the documentation
20 override_dh_auto_build:
21         dh_auto_build
22         PYTHONPATH=. http_proxy='127.0.0.1:9' make doc
23
24 # ... and clean it
25 override_dh_auto_clean:
26         dh_auto_clean
27         $(MAKE) clean
28
29 override_dh_strip:
30         dh_strip -ppython-pyxattr --dbgsym-migration='python-pyxattr-dbg (<<0.6.1-1~)'
31         dh_strip -ppython3-pyxattr --dbgsym-migration='python3-pyxattr-dbg (<<0.6.1-1~)'
32
33 override_dh_installdocs:
34         dh_installdocs -A --remaining-packages README.rst
35
36 override_dh_installchangelogs:
37         dh_installchangelogs -A NEWS