]> git.k1024.org Git - debian-pyxattr.git/blob - debian/rules
Fixed clean rule
[debian-pyxattr.git] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 #
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets  by Bill Allombert 2001
7
8 # Uncomment this to turn on verbose mode.
9 #export DH_VERBOSE=1
10
11 # This has to be exported to make some magic below work.
12 export DH_OPTIONS
13
14 PYVERS := $(shell pyversions -vr)
15
16 build: $(PYVERS:%=build-python%) build-indep
17         touch $@
18
19 build-python%:
20         python$* setup.py build
21         touch $@
22
23 build-indep:
24         ./setup.py build_ext -i && epydoc --config epydoc.conf
25         touch $@
26
27 clean:
28         dh_testdir
29         dh_testroot
30         rm -f build-arch-stamp build-indep #CONFIGURE-STAMP#
31         rm -rf build html
32         rm -f xattr.so
33         rm -f $(PYVERS:%=build-python%)
34         dh_clean 
35
36 install: build $(PYVERS:%=install-python%)
37
38 install-python%:
39         python$* setup.py install --root $(CURDIR)/debian/python-pyxattr
40
41 # Build architecture-dependent files here.
42 binary-arch: build install
43         dh_testdir
44         dh_testroot
45         dh_installchangelogs
46         dh_installdocs
47         dh_strip
48         dh_compress -X.js
49         dh_fixperms
50         dh_pysupport
51         dh_installdeb
52         dh_shlibdeps
53         dh_gencontrol
54         dh_md5sums
55         dh_builddeb
56
57 # Build architecture independant packages here.
58 binary-indep: build install
59 # Nothing to do
60
61 binary: binary-arch binary-indep
62 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure