3 # Uncomment this to turn on verbose mode.
6 # This has to be exported to make some magic below work.
9 export PYBUILD_NAME = pyxattr
11 export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
12 DPKG_EXPORT_BUILDFLAGS = 1
13 include /usr/share/dpkg/buildflags.mk
16 dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
18 override_dh_auto_build:
20 PYTHONPATH=. http_proxy='127.0.0.1:9' make doc
23 dh_strip -ppython-pyxattr --dbgsym-migration='python-pyxattr-dbg (<< 0.5.6-1~)'
24 dh_strip -ppython3-pyxattr --dbgsym-migration='python3-pyxattr-dbg (<< 0.5.6-1~)'
26 override_dh_auto_test:
27 echo "Tests need an xattr-enabled filesystem, not running by default"