2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets by Bill Allombert 2001
8 # Uncomment this to turn on verbose mode.
11 # This has to be exported to make some magic below work.
14 PYVERS := $(shell pyversions -r)
16 configure: configure-stamp
23 build: build-arch build-indep
25 build-arch: build-arch-stamp
26 build-arch-stamp: configure-stamp
27 set -e; for py in $(PYVERS); do \
28 $$py setup.py build; done
30 touch build-arch-stamp
32 build-indep: build-indep-stamp
33 build-indep-stamp: configure-stamp
34 touch build-indep-stamp
39 rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
49 set -e; for py in $(PYVERS); do \
50 $$py setup.py install --root=$(CURDIR)/debian/python-pyxattr; \
52 rm -rf $(CURDIR)/debian/python-pyxattr/usr/share/doc/pyxattr-0.2.1
54 # Build architecture-dependent files here.
55 binary-arch: build install
58 dh_installchangelogs ChangeLog
59 dh_installdocs -A README NEWS xattr.txt
70 # Build architecture independant packages here.
71 binary-indep: build install
74 binary: binary-arch binary-indep
75 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure