f7a8f3db21f6516824dbb5c2a9cbb3a7e4b49152
[debian-pylibacl.git] / changelog
1 python-pylibacl (0.5.4-4) UNRELEASED; urgency=low
2
3   * Use secure URI in Homepage field.
4   * Fix field name case in debian/copyright (Upstream-name => Upstream-Name).
5
6  -- Debian Janitor <janitor@jelmer.uk>  Tue, 07 Jul 2020 15:03:35 -0000
7
8 python-pylibacl (0.5.4-3) unstable; urgency=medium
9
10   * Remove python-setuptools dependency, not needed, and allows really
11     fixing the Python 2 bug (Closes: #938073).
12   * Bump standards version (no changes needed).
13
14  -- Iustin Pop <iustin@debian.org>  Mon, 20 Apr 2020 23:37:21 +0200
15
16 python-pylibacl (0.5.4-2) unstable; urgency=medium
17
18   * Drop python2 support; Closes: #938073
19
20  -- Sandro Tosi <morph@debian.org>  Tue, 17 Mar 2020 11:54:20 -0400
21
22 python-pylibacl (0.5.4-1) unstable; urgency=medium
23
24   * New upstream release, switching build system to Python 3.
25
26  -- Iustin Pop <iustin@debian.org>  Thu, 14 Nov 2019 12:25:21 +0100
27
28 python-pylibacl (0.5.3-2) unstable; urgency=medium
29
30   * Refresh packaging for upcoming release:
31     - switch Vcs URLs to Salsa
32     - switch watch file and copyright URLs to https
33     - update standards version (remove 'extra' priority)
34     - drop obsolete Xs-Python* headers
35     - add Rules-Requires-Root: no
36     - switch to debhelper compat level 12
37   * Do a source-full upload to include upstream tarball signature in the
38     archive.
39
40  -- Iustin Pop <iustin@debian.org>  Thu, 03 Jan 2019 10:16:25 +0100
41
42 python-pylibacl (0.5.3-1) unstable; urgency=medium
43
44   * Imported Upstream version 0.5.3; main changes:
45     - improve FreeBSD support
46     - fix qualifier overflow issues due to wrong types
47   * Improve hardening of the package (all except pie, which breaks the
48     build)
49   * Switch debian/copyright to dep5
50   * Switch debian packaging repo over to alioth
51   * Switch build system to dh and pybuild
52   * Split documentation into separate package, in order to reduce the
53     dependencies for the python2 package
54   * Add autopkg tests
55
56  -- Iustin Pop <iustin@debian.org>  Sun, 15 May 2016 05:45:03 +0200
57
58 python-pylibacl (0.5.2-2) unstable; urgency=medium
59
60   * Fix building with Sphinx 1.3 (Closes: #787172).
61
62  -- Iustin Pop <iustin@debian.org>  Mon, 29 Jun 2015 21:49:45 +0200
63
64 python-pylibacl (0.5.2-1) unstable; urgency=medium
65
66   * New minor upstream release: only fixes to unittests
67   * Update watch file to point at the new downloads location
68   * Standards version 3.9.5 (no changes needed)
69
70  -- Iustin Pop <iustin@debian.org>  Mon, 21 Jul 2014 05:22:46 +0200
71
72 python-pylibacl (0.5.1-1) unstable; urgency=low
73
74   * New upstream version: bugfixes for refcount leaks and possible
75     NULL-pointer dereferences
76   * Add packages for Python3
77   * Switch from python-support to dh_python2/dh_python3
78   * Standards Version 3.9.3 (no changes needed)
79
80  -- Iustin Pop <iustin@debian.org>  Sun, 13 May 2012 22:19:00 +0200
81
82 python-pylibacl (0.5.0-3) unstable; urgency=low
83
84   * Remove old Replaces/Breaks
85
86  -- Iustin Pop <iustin@debian.org>  Tue, 17 Aug 2010 23:18:13 +0200
87
88 python-pylibacl (0.5.0-2) unstable; urgency=low
89
90   * Apply a modified version of the Ubuntu patch for enabling debug
91     packages, thanks Bhavani Shankar R (Closes: #591367).
92   * Standards Version 3.9.1 (Use Breaks instead of Conflicts).
93
94  -- Iustin Pop <iustin@debian.org>  Thu, 05 Aug 2010 15:50:28 -0400
95
96 python-pylibacl (0.5.0-1) unstable; urgency=low
97
98   * New upstream release
99   * Switch to my Debian address and remove DM-Upload-Allowed
100   * Standards version 3.8.4 (no changes needed)
101   * Switch to dpkg-source 3.0 (quilt) format
102
103  -- Iustin Pop <iustin@debian.org>  Wed, 03 Mar 2010 01:15:18 +0100
104
105 python-pylibacl (0.4.0-3) unstable; urgency=low
106
107   * Fixes "FTBFS on Debian GNU/Hurd [Patch]" (added patch by
108     bdefreese@debian.org) (Closes: #534123)
109   * Fixed lintian copyright format warning
110   * Added Vcs-* and DM-* fields to debian/control
111   * Update standard version to 3.8.2 (no changes required)
112
113  -- Iustin Pop <iusty@k1024.org>  Tue, 23 Jun 2009 23:01:01 +0200
114
115 python-pylibacl (0.4.0-2) unstable; urgency=low
116
117   * Removed debian/pycompat (not needed with recent pysupport)
118   * Fixed clean rule (Closes: #488763)
119
120  -- Iustin Pop <iusty@k1024.org>  Tue, 01 Jul 2008 11:24:38 +0200
121
122 python-pylibacl (0.4.0-1) unstable; urgency=low
123
124   * New Upstream Version, with license changed from GPL to LGPL
125   * Update to Policy 3.8.0
126   * Update the rules file for newer pysupport version
127   * Update debhelper compat level to 7
128   * Added watch file
129
130  -- Iustin Pop <iusty@k1024.org>  Sun, 29 Jun 2008 00:40:25 +0200
131
132 python-pylibacl (0.3.0-1) unstable; urgency=low
133
134   * New Upstream Version (more functionality implemented from libacl)
135   * Fix lintian warnings
136
137  -- Iustin Pop <iusty@k1024.org>  Tue, 26 Feb 2008 21:59:12 +0100
138
139 python-pylibacl (0.2.2-1) unstable; urgency=low
140
141   * New upstream release (add support for building on GNU/kFreeBSD, removes
142     some warnings) (Closes: #401316).
143   * Acknowledge NMU by Pierre Habouzit. Thanks! (Closes: #373342).
144
145  -- Iustin Pop <iusty@k1024.org>  Sun,  3 Dec 2006 13:56:24 +0100
146
147 python-pylibacl (0.2.1-3.1) unstable; urgency=low
148
149   * Non-maintainer upload.
150   * Update package for the last python policy (Closes: #373342).
151
152  -- Pierre Habouzit <madcoder@debian.org>  Sun,  2 Jul 2006 15:07:24 +0200
153
154 python-pylibacl (0.2.1-3) unstable; urgency=low
155
156   * Stop building python 2.2 packages (closes: #351149)
157   * Start building python 2.4 packages
158   * Updated standards version to 3.6.2 (no changes)
159   * Updated FSF address in copyright file
160
161  -- Iustin Pop <iusty@k1024.org>  Wed, 22 Feb 2006 13:13:14 +0200
162
163 python-pylibacl (0.2.1-2) unstable; urgency=low
164
165   * Fixed missing dependency on python (closes: #258483)
166   * Updates to standards version 3.6.1
167
168  -- Iustin Pop <iusty@k1024.org>  Sun, 11 Jul 2004 02:14:01 +0300
169
170 python-pylibacl (0.2.1-1) unstable; urgency=low
171
172   * Initial Release.
173
174  -- Iustin Pop <iusty@k1024.org>  Tue, 16 Sep 2003 21:49:37 +0300