Remove compatibility with old recommonmark versions
[pyxattr.git] / .travis.yml
1 language: python
2
3 # enable caching of installed packages.
4 cache: pip
5
6 # let's test as many versions as we can!
7 python:
8     - "3.4"
9     - "3.5"
10     - "3.6"
11     - "3.7"
12     - "3.8"
13     - "3.9-dev"
14     - "nightly"
15
16 # enable OSX support, with only system Python, and newer Python on Linux:
17 #matrix:
18 #  include:
19 #    - os: osx
20 #      # specify a reasonably newer xcode so that brew works
21 #      osx_image: xcode11
22 #      language: generic
23 #      python:
24
25 # install coverage helper:
26 install:
27   - gem install coveralls-lcov
28   - pip install pytest
29   - pip install codecov
30
31 # the test command:
32 script:
33   - python ./setup.py build_ext -i
34   - python -m pytest tests
35   - make clean
36   - CFLAGS="-coverage" python ./setup.py build_ext -i
37   - python -m pytest tests
38
39 # install lcov, platform-specific but clean:
40 addons:
41   apt:
42     packages:
43       - lcov
44   homebrew:
45     packages:
46       - lcov
47
48 after_success:
49   - lcov --capture --no-external --directory . --output-file coverage.info
50   - COVERALLS_PARALLEL=true coveralls-lcov coverage.info
51   - codecov
52
53 notifications:
54   webhooks: https://coveralls.io/webhook