From a9c2e960188ab295027929a8435f994b3b110378 Mon Sep 17 00:00:00 2001
From: Iustin Pop <iustin@debian.org>
Date: Thu, 19 Jan 2023 13:24:28 +0100
Subject: [PATCH] New upstream version 0.8.0

---
 MANIFEST.in                  |   2 +
 Makefile                     |  11 +-
 NEWS                         |  15 ++
 PKG-INFO                     |  14 +-
 README.md                    |  30 ++--
 doc/conf.py                  |  10 +-
 doc/news.rst                 | 257 +++++++++++++++++++++++++++++++++++
 doc/readme.md                |  76 +++++++++++
 pyxattr.egg-info/PKG-INFO    |  14 +-
 pyxattr.egg-info/SOURCES.txt |   2 +
 setup.py                     |   3 +-
 tests/test_xattr.py          |   5 +
 xattr.c                      |  47 +++----
 13 files changed, 418 insertions(+), 68 deletions(-)
 create mode 100644 doc/news.rst
 create mode 100644 doc/readme.md

diff --git a/MANIFEST.in b/MANIFEST.in
index 4960670..4c29306 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -5,6 +5,8 @@ include Makefile
 include doc/conf.py
 include doc/index.rst
 include doc/module.rst
+include doc/news.md
+include doc/readme.md
 include setup.cfg
 include tests/test_xattr.py
 include tests/__init__.py
diff --git a/Makefile b/Makefile
index f57b8bf..0fe2199 100644
--- a/Makefile
+++ b/Makefile
@@ -5,13 +5,13 @@ DOCDIR        = doc
 DOCHTML       = $(DOCDIR)/html
 DOCTREES      = $(DOCDIR)/doctrees
 ALLSPHINXOPTS = -d $(DOCTREES) $(SPHINXOPTS) $(DOCDIR)
-VERSION       = 0.7.2
+VERSION       = 0.8.0
 FULLVER       = pyxattr-$(VERSION)
 DISTFILE      = $(FULLVER).tar.gz
 
 MODNAME = xattr.so
 RSTFILES = doc/index.rst doc/module.rst doc/news.rst doc/readme.md doc/conf.py
-PYVERS = 3.4 3.5 3.6 3.7 3.8 3.9
+PYVERS = 3.7 3.8 3.9 3.10
 REPS = 5
 
 all: doc test
@@ -25,12 +25,6 @@ $(DOCHTML)/index.html: $(MODNAME) $(RSTFILES)
 
 doc: $(DOCHTML)/index.html
 
-doc/readme.md: README.md
-	ln -s ../README.md doc/readme.md
-
-doc/news.rst: NEWS
-	ln -s ../NEWS doc/news.rst
-
 dist:
 	fakeroot $(PYTHON) ./setup.py sdist
 
@@ -89,7 +83,6 @@ coverage:
 
 clean:
 	rm -rf $(DOCHTML) $(DOCTREES)
-	rm -f doc/readme.md doc/news.rst
 	rm -f $(MODNAME)
 	rm -f *.so
 	rm -rf build
diff --git a/NEWS b/NEWS
index 87caf52..d92f428 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,21 @@
 News
 ====
 
+Version 0.8.0
+-------------
+
+*Mon, 12 Dec 2022*
+
+Minor bugfix release, but due to lack of CI environments supporting old
+Python versions, only Python 3.7+ is supported. Otherwise:
+
+* Snape3058@ found some refcount issues (see issue #35), these have been
+  fixed.
+* Tested and enabled Python 3.10 support, dropped < 3.7.
+* Various improvements to the CI environments.
+* Move fully to `setuptools` (where available), in preparation for 3.12
+  dropping `distutils` support.
+
 Version 0.7.2
 -------------
 
diff --git a/PKG-INFO b/PKG-INFO
index efe5a0c..b088a2d 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,16 +1,13 @@
-Metadata-Version: 1.2
+Metadata-Version: 2.1
 Name: pyxattr
-Version: 0.7.2
+Version: 0.8.0
 Summary: Filesystem extended attributes for python
 Home-page: http://pyxattr.k1024.org/
+Download-URL: http://pyxattr.k1024.org/downloads/
 Author: Iustin Pop
 Author-email: iustin@k1024.org
 License: LGPL
-Download-URL: http://pyxattr.k1024.org/downloads/
 Project-URL: Bug Tracker, https://github.com/iustin/pyxattr/issues
-Description: This is a C extension module for Python which
-        implements extended attributes manipulation. It is a wrapper on top
-        of the attr C library - see attr(5).
 Platform: Linux
 Classifier: Development Status :: 5 - Production/Stable
 Classifier: Intended Audience :: Developers
@@ -23,3 +20,8 @@ Classifier: Operating System :: POSIX :: Linux
 Classifier: Topic :: Software Development :: Libraries :: Python Modules
 Classifier: Topic :: System :: Filesystems
 Requires-Python: >=3.4
+License-File: COPYING
+
+This is a C extension module for Python which
+implements extended attributes manipulation. It is a wrapper on top
+of the attr C library - see attr(5).
diff --git a/README.md b/README.md
index 693be67..59e5c0f 100644
--- a/README.md
+++ b/README.md
@@ -4,7 +4,7 @@ This is the pyxattr module, a Python extension module which gives access
 to the extended attributes for filesystem objects available in some
 operating systems.
 
-[![Travis](https://img.shields.io/travis/iustin/pyxattr)](https://travis-ci.org/iustin/pyxattr)
+[![GitHub Workflow Status](https://img.shields.io/github/workflow/status/iustin/pyxattr/CI)](https://github.com/iustin/pyxattr/actions/workflows/ci.yml)
 [![Codecov](https://img.shields.io/codecov/c/github/iustin/pyxattr)](https://codecov.io/gh/iustin/pyxattr)
 [![Read the Docs](https://img.shields.io/readthedocs/pyxattr)](http://pyxattr.readthedocs.io/en/latest/?badge=latest)
 [![GitHub issues](https://img.shields.io/github/issues/iustin/pyxattr)](https://github.com/iustin/pyxattr/issues)
@@ -23,23 +23,31 @@ repository is either at <http://git.k1024.org/pyxattr.git> or at
 
 ## Requirements
 
-The current supported Python versions are 3.4+ (tested up to 3.9).
+The current supported Python versions are 3.7+ (tested up to 3.10), or
+PyPy versions 3.7+ (tested up to 3.9). The code should currently be
+compatible down to Python 3.4, but such versions are no longer tested.
 
 The library has been written and tested on Linux, kernel v2.4 or
-later, with XFS and ext2/ext3/ext3 file systems. If any other platform
-implements the same behaviour, pyxattr could be used.
+later, with XFS and ext2/ext3/ext4 file systems, and MacOS recent
+versions. If any other platform implements the same behaviour,
+pyxattr could be used.
 
-You need to have the setuptools tool installed in order to build and
-install the module, and for building the documentation you need to
-have Sphinx installed.
+To build the module from source, you will need both a Python
+development environment/libraries and the C compiler, plus the
+setuptools tool installed, and for building the documentation you need
+to have Sphinx installed. The exact list of dependencies depends on
+the operating system/distribution, but should be something along the
+lines of `python3-devel` (RedHat), `python3-all-dev` (Debian), etc.
 
-Alternatively, you can install directly from pip:
+Alternatively, you can install directly from pip after installing the
+above depedencies (C compiler, Python development libraries):
 
-    $ pip install pyxattr
+    pip install pyxattr
 
-Or from your distribution, e.g. in Debian:
+Or you can install already compiled versions from your distribution,
+e.g. in Debian:
 
-    $ sudo apt install python3-pyxattr
+    sudo apt install python3-pyxattr
 
 ## Basic example
 
diff --git a/doc/conf.py b/doc/conf.py
index c48b6d7..f5b8ed8 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,9 +48,9 @@ copyright = u'2002, 2003, 2006, 2008, 2012, 2013, 2014, 2015, Iustin Pop'
 # built documents.
 #
 # The short X.Y version.
-version = '0.7.2'
+version = '0.8.0'
 # The full version, including alpha/beta/rc tags.
-release = '0.7.2'
+release = '0.8.0'
 
 # The language for content autogenerated by Sphinx. Refer to documentation
 # for a list of supported languages.
@@ -90,12 +90,6 @@ pygments_style = 'sphinx'
 
 keep_warnings = True
 
-# Note: this is still needed in Sphinx 1.8 with recommonmark 0.4.0
-# (https://github.com/readthedocs/recommonmark/issues/119):
-source_parsers = {
-   '.md': 'recommonmark.parser.CommonMarkParser',
-}
-
 # -- Options for HTML output ---------------------------------------------------
 
 # The theme to use for HTML and HTML Help pages.  See the documentation for
diff --git a/doc/news.rst b/doc/news.rst
new file mode 100644
index 0000000..d92f428
--- /dev/null
+++ b/doc/news.rst
@@ -0,0 +1,257 @@
+News
+====
+
+Version 0.8.0
+-------------
+
+*Mon, 12 Dec 2022*
+
+Minor bugfix release, but due to lack of CI environments supporting old
+Python versions, only Python 3.7+ is supported. Otherwise:
+
+* Snape3058@ found some refcount issues (see issue #35), these have been
+  fixed.
+* Tested and enabled Python 3.10 support, dropped < 3.7.
+* Various improvements to the CI environments.
+* Move fully to `setuptools` (where available), in preparation for 3.12
+  dropping `distutils` support.
+
+Version 0.7.2
+-------------
+
+*Sun, 29 Nov 2020*
+
+Minor release:
+
+* Expand testing by adding better mixed-access checks (e.g. set via
+  symlink and read on file) and by not leaking resources during tests.
+* Enable testing with Python 3.9 and confirm compatibility with it.
+* Fix documentation building with Sphinx 3.0+.
+
+Version 0.7.1
+-------------
+
+*released Tue, 26 Nov 2019*
+
+Typo fix release in the bug tracker link :/
+
+Version 0.7.0
+-------------
+
+*released Tue, 26 Nov 2019*
+
+Major change: drop compatibility with Python 2, which allows significant
+code cleanups.
+
+Other changes:
+
+* Switch internal implementation of argument parsing to a built-in one
+  (`PyUnicode_FSConverter`), which brings automatic support for
+  path-like objects in Python 3.6+ (#20), and also a more uniform
+  handling of Unicode path arguments with respect to other Python code.
+* Fix missing error check in list operations in `get_all` (#17).
+* Switch test library to pytest; not that a reasonable recent version is
+  needed. Additionally, expand test coverage, although not directly
+  visible in actual coverage reports…
+
+Version 0.6.1
+-------------
+
+*released Tue, 24 Jul 2018*
+
+Minor bugfix, performance and compatibility release.
+
+* Minor compatibility fix: on Linux, drop the use of the `attr` library,
+  and instead switch to the glibc header `sys/xattr.h`, which is
+  provided for a really long time (since glibc 2.3). The formerly used
+  header `attr/xattr.h` has been removed from the `attr` library in
+  version 2.4.48. Fix provided by Lars Wendler, many thanks!
+* Release the GIL when performing I/O. Patch proposed by xwhuang, many
+  thanks. I tested this a long while back it seemed to impact
+  performance on local filesystems, but upon further inspection, the
+  downsides are minor (between 0 and 5%, in many cases negligible). For
+  remote or slow filesystems, this should allow much increased
+  parallelism.
+* Fix symlink set operation on MacOS X; bugfix provided by adamlin, much
+  appreciated! This also uncovered testing problems related to symlinks,
+  which are now fixed (the bug would be caught by the updated tests).
+
+Version 0.6.0
+-------------
+
+*released Mon, 23 Jan 2017*
+
+Bugfix and feature release (hence the version bump).
+
+The main change is to the implementation of how attributes are listed
+and read. This was done due to existing race issues when attributes are
+modified while being read (github issue #12), but basically all various
+internal paths that dealt with retrieving an attribute value or listing
+attributes were unified in a single helper function that does handle
+such concurrent modifications. As a side effect, the size of the buffers
+used for such reads have changed, which (depending on attribute value)
+might change the trade-off between number of syscalls done and memory
+usage.
+
+As feature release, OSX support was contributed by Adam Knight
+<adam@movq.us>, thanks a lot! I don't have access to OSX so the testing
+for it is done via Travis builds; please report any issues.
+
+Version 0.5.6
+-------------
+
+*released Sat, 09 Apr 2016*
+
+Small bugfix release:
+
+* Fixes some sign-compare warnings
+* Fixes potential name truncation in merge_ns()
+* Fixes building on systems which don't have ENODATA
+
+Tested with Python 2.7.11, Python 3.5.1 and PyPy 5.0.1.
+
+Version 0.5.5
+-------------
+
+*released Fri, 01 May 2015*
+
+Bugfix release:
+
+* fixes some more memory leaks when handling out-of-memory in get_all()
+  function
+* improve error reporting when an attribute disappears after we asked
+  for its length but before we managed to read it
+* fix int/size_t issues found by RedHat/Fedora,
+  https://bugzilla.redhat.com/show_bug.cgi?id=1127310; the fix is
+  different than their fix, but it should accomplish the same thing
+* convert all code to only do explicit casts after checking boundaries,
+  making the code `-Wconversion`-clean (although that warning is not
+  enabled by default)
+
+Version 0.5.4
+-------------
+
+*released Thu, 30 Apr 2015*
+
+Fix memory leaks on some of the error-handling paths of the `get()`
+function.
+
+Version 0.5.3
+-------------
+
+*released Fri, 23 May 2014*
+
+Small optimisations release:
+
+* ari edelkind contributed a speed-up optimisation for handling of files
+  without xattrs (which is, in general, the expected case)
+* Jonas Borgström contributed a behaviour change to the handling of file
+  names: under Python 3 and up, unicode paths are encoded/decoded using
+  the 'surogatee' handler, instead of the 'strict' handler; while this
+  can hide encoding errors, it mirrors what Python libraries do
+  (e.g. see os.fsencode/fsdecode)
+* Sean Patrick Santos contributed improvements to the test suite so that
+  it can be used even on files systems which have built-in attributes
+  (e.g. when using SELinux, or NFSv4); to enable this, define the
+  attributes in the TEST_IGNORE_XATTRS environment variable
+
+Version 0.5.2
+-------------
+
+*released Thu, 03 Jan 2013*
+
+Bug-fix release. Thanks to Michał Górny, it looked like the library had
+problem running under pypy, but actually there was a bug in the
+PyArg_ParseTuple use of et# (signed vs. unsigned, and lack of compiler
+warnings). This was fixed, and now the test suite passed with many
+CPython versions and PyPy (version 1.9).
+
+Version 0.5.1
+-------------
+
+*released Wed, 16 May 2012*
+
+Bug-fix release. Thanks to Dave Malcolm and his cpychecker tool, a
+number of significant bugs (refcount leaks and potential NULL-pointer
+dereferences) have been fixed.
+
+Furthermore, compatibility with Python 3 has been improved; this however
+required changing the meaning of the ``namespace`` argument to the
+functions: if passed, None is no longer a valid value; pass an empty
+string if (due to the structure of your program) you have to pass this
+argument but want to specify no namespace.
+
+Also, the project home page has changed from SourceForge to GitHub, and
+the documentation has been converted from epydoc-based to sphinx.
+
+
+Version 0.5
+-----------
+
+*released Sun, 27 Dec 2009*
+
+Implemented support for Python 3. This required a significant change to
+the C module, hence the new version number.
+
+Version 0.4
+-----------
+
+*released Mon, 30 Jun 2008*
+
+API
+~~~
+
+The old functions ({get,set,list,remove}xattr) are deprecated and replaced with
+a new API that is namespace-aware and hopefully will allow other OSes (e.g.
+FreeBSD) to be supported more naturally.
+
+Both the old and the new API are supported in the 0.4 versions, however users
+are encouraged to migrate to the new API.
+
+New features
+~~~~~~~~~~~~
+
+A new bulk get function called get_all() has been added that should be somewhat
+faster in case of querying files which have many attributes.
+
+License
+~~~~~~~
+
+Since LGPLv3 is not compatible with GPLv2 (which unfortunately I didn't realize
+before), the license was changed to LGPLv2.1 or later.
+
+Internals
+~~~~~~~~~
+
+Unittest coverage was improved.
+
+Version 0.3
+-----------
+
+*released Sun, 09 Mar 2008*
+
+* changed licence from GPL to LGPL (3 or later)
+* changed listxattr return type from tuple to a list
+* developer-related: added unittests
+
+Version 0.2.2
+-------------
+
+*released Sun, 01 Jul 2007*
+
+* fixed listing symlink xattrs
+
+Version 0.2.1
+-------------
+
+*released Sat, 11 Feb 2006*
+
+* fixed a bug when reading symlink EAs (you weren't able to
+  do it, actually)
+* fixed a possible memory leak when the actual read of the EA
+  failed but the call to get the length of the EA didn't
+
+.. Local Variables:
+.. mode: rst
+.. fill-column: 72
+.. End:
diff --git a/doc/readme.md b/doc/readme.md
new file mode 100644
index 0000000..59e5c0f
--- /dev/null
+++ b/doc/readme.md
@@ -0,0 +1,76 @@
+# pyxattr
+
+This is the pyxattr module, a Python extension module which gives access
+to the extended attributes for filesystem objects available in some
+operating systems.
+
+[![GitHub Workflow Status](https://img.shields.io/github/workflow/status/iustin/pyxattr/CI)](https://github.com/iustin/pyxattr/actions/workflows/ci.yml)
+[![Codecov](https://img.shields.io/codecov/c/github/iustin/pyxattr)](https://codecov.io/gh/iustin/pyxattr)
+[![Read the Docs](https://img.shields.io/readthedocs/pyxattr)](http://pyxattr.readthedocs.io/en/latest/?badge=latest)
+[![GitHub issues](https://img.shields.io/github/issues/iustin/pyxattr)](https://github.com/iustin/pyxattr/issues)
+![GitHub tag (latest by date)](https://img.shields.io/github/v/tag/iustin/pyxattr)
+[![GitHub release (latest by date)](https://img.shields.io/github/v/release/iustin/pyxattr)](https://github.com/iustin/pyxattr/releases)
+[![PyPI](https://img.shields.io/pypi/v/pyxattr)](https://pypi.org/project/pyxattr/)
+![Debian package](https://img.shields.io/debian/v/python-pyxattr)
+![Ubuntu package](https://img.shields.io/ubuntu/v/python-pyxattr)
+![GitHub Release Date](https://img.shields.io/github/release-date/iustin/pyxattr)
+![GitHub commits since latest release](https://img.shields.io/github/commits-since/iustin/pyxattr/latest)
+![GitHub last commit](https://img.shields.io/github/last-commit/iustin/pyxattr)
+
+Downloads: go to <https://pyxattr.k1024.org/downloads/>. The source
+repository is either at <http://git.k1024.org/pyxattr.git> or at
+<https://github.com/iustin/pyxattr>.
+
+## Requirements
+
+The current supported Python versions are 3.7+ (tested up to 3.10), or
+PyPy versions 3.7+ (tested up to 3.9). The code should currently be
+compatible down to Python 3.4, but such versions are no longer tested.
+
+The library has been written and tested on Linux, kernel v2.4 or
+later, with XFS and ext2/ext3/ext4 file systems, and MacOS recent
+versions. If any other platform implements the same behaviour,
+pyxattr could be used.
+
+To build the module from source, you will need both a Python
+development environment/libraries and the C compiler, plus the
+setuptools tool installed, and for building the documentation you need
+to have Sphinx installed. The exact list of dependencies depends on
+the operating system/distribution, but should be something along the
+lines of `python3-devel` (RedHat), `python3-all-dev` (Debian), etc.
+
+Alternatively, you can install directly from pip after installing the
+above depedencies (C compiler, Python development libraries):
+
+    pip install pyxattr
+
+Or you can install already compiled versions from your distribution,
+e.g. in Debian:
+
+    sudo apt install python3-pyxattr
+
+## Basic example
+
+    >>> import xattr
+    >>> xattr.listxattr("file.txt")
+    ['user.mime_type']
+    >>> xattr.getxattr("file.txt", "user.mime_type")
+    'text/plain'
+    >>> xattr.setxattr("file.txt", "user.comment", "Simple text file")
+    >>> xattr.listxattr("file.txt")
+    ['user.mime_type', 'user.comment']
+    >>> xattr.removexattr ("file.txt", "user.comment")
+
+## License
+
+pyxattr is Copyright 2002-2008, 2012-2015 Iustin Pop.
+
+pyxattr is free software; you can redistribute it and/or modify it under the
+terms of the GNU Lesser General Public License as published by the Free
+Software Foundation; either version 2.1 of the License, or (at your option) any
+later version. See the COPYING file for the full license terms.
+
+Note that previous versions had different licenses: version 0.3 was licensed
+under LGPL version 3 (which, I realized later, is not compatible with GPLv2,
+hence the change to LGPL 2.1), and even older versions were licensed under GPL
+v2 or later.
diff --git a/pyxattr.egg-info/PKG-INFO b/pyxattr.egg-info/PKG-INFO
index efe5a0c..b088a2d 100644
--- a/pyxattr.egg-info/PKG-INFO
+++ b/pyxattr.egg-info/PKG-INFO
@@ -1,16 +1,13 @@
-Metadata-Version: 1.2
+Metadata-Version: 2.1
 Name: pyxattr
-Version: 0.7.2
+Version: 0.8.0
 Summary: Filesystem extended attributes for python
 Home-page: http://pyxattr.k1024.org/
+Download-URL: http://pyxattr.k1024.org/downloads/
 Author: Iustin Pop
 Author-email: iustin@k1024.org
 License: LGPL
-Download-URL: http://pyxattr.k1024.org/downloads/
 Project-URL: Bug Tracker, https://github.com/iustin/pyxattr/issues
-Description: This is a C extension module for Python which
-        implements extended attributes manipulation. It is a wrapper on top
-        of the attr C library - see attr(5).
 Platform: Linux
 Classifier: Development Status :: 5 - Production/Stable
 Classifier: Intended Audience :: Developers
@@ -23,3 +20,8 @@ Classifier: Operating System :: POSIX :: Linux
 Classifier: Topic :: Software Development :: Libraries :: Python Modules
 Classifier: Topic :: System :: Filesystems
 Requires-Python: >=3.4
+License-File: COPYING
+
+This is a C extension module for Python which
+implements extended attributes manipulation. It is a wrapper on top
+of the attr C library - see attr(5).
diff --git a/pyxattr.egg-info/SOURCES.txt b/pyxattr.egg-info/SOURCES.txt
index f9162da..14ef93e 100644
--- a/pyxattr.egg-info/SOURCES.txt
+++ b/pyxattr.egg-info/SOURCES.txt
@@ -9,6 +9,8 @@ xattr.c
 doc/conf.py
 doc/index.rst
 doc/module.rst
+doc/news.rst
+doc/readme.md
 pyxattr.egg-info/PKG-INFO
 pyxattr.egg-info/SOURCES.txt
 pyxattr.egg-info/dependency_links.txt
diff --git a/setup.py b/setup.py
index ac5c82b..d4b2c72 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,5 @@
 #!/usr/bin/env python3
 
-import distutils
 import platform
 try:
   from setuptools import setup, Extension
@@ -10,7 +9,7 @@ except ImportError:
 long_desc = """This is a C extension module for Python which
 implements extended attributes manipulation. It is a wrapper on top
 of the attr C library - see attr(5)."""
-version = "0.7.2"
+version = "0.8.0"
 author = "Iustin Pop"
 author_email = "iustin@k1024.org"
 libraries = []
diff --git a/tests/test_xattr.py b/tests/test_xattr.py
index 4f3e663..40183f8 100644
--- a/tests/test_xattr.py
+++ b/tests/test_xattr.py
@@ -151,6 +151,10 @@ NOT_BEFORE_36 = pytest.mark.xfail(condition="sys.version_info < (3,6)",
 NOT_PYPY = pytest.mark.xfail(condition="platform.python_implementation() == 'PyPy'",
                                   strict=False)
 
+NOT_MACOSX = pytest.mark.xfail(condition="sys.platform.startswith('darwin')",
+                               reason="Test not supported on MacOS",
+                               strict=True)
+
 # Note: user attributes are only allowed on files and directories, so
 # we have to skip the symlinks here. See xattr(7).
 ITEMS_P = [
@@ -438,6 +442,7 @@ def test_binary_payload(subject):
     assert xattr.get_all(item, namespace=NAMESPACE) == [(USER_NN, BINVAL)]
     xattr.remove(item, USER_ATTR)
 
+@NOT_MACOSX
 def test_symlinks_user_fail(testdir, use_dangling):
     _, sname = get_symlink(testdir, dangling=use_dangling)
     with pytest.raises(IOError):
diff --git a/xattr.c b/xattr.c
index e118f79..31ad87f 100644
--- a/xattr.c
+++ b/xattr.c
@@ -311,13 +311,11 @@ static int _remove_obj(target_t *tgt, const char *name) {
  * - buffer: pointer to either an already allocated memory area (in
  *   which case size contains its current size), or NULL to
  *   allocate. In all cases (success or failure), the caller should
- *   deallocate the buffer, using PyMem_Free(). Note that if size is
- *   zero but buffer already points to allocate memory, it will be
- *   ignored/leaked.
+ *   deallocate the buffer, using PyMem_Free().
  * - size: either size of current buffer (if non-NULL), or size for
- *   initial allocation (if non-zero), or a zero value which means
- *   auto-allocate buffer with automatically queried size. Value will
- *   be updated upon return with the current buffer size.
+ *   initial allocation; zero means use a hardcoded initial buffer
+ *   size (ESTIMATE_ATTR_SIZE). The value will be updated upon return
+ *   with the current buffer size.
  * - io_errno: if non-NULL, the actual errno will be recorded here; if
  *   zero, the call was successful and the output/size/nval are valid.
  *
@@ -354,18 +352,9 @@ static ssize_t _generic_get(buf_getter getter, target_t *tgt,
   }
 
   /* Initialize the buffer, if needed. */
-  if (*size == 0 || *buffer == NULL) {
-    if (*size == 0) {
-      ssize_t nalloc;
-      if ((nalloc = getter(tgt, name, NULL, 0)) == -1) {
-        EXIT_IOERROR();
-      }
-      if (nalloc == 0) {
-        /* Empty, so no need to retrieve it. */
-        return 0;
-      }
-      *size = nalloc;
-    }
+  if (*buffer == NULL) {
+    if (*size == 0)
+      *size = ESTIMATE_ATTR_SIZE;
     if((*buffer = PyMem_Malloc(*size)) == NULL) {
       PyErr_NoMemory();
       return -1;
@@ -443,7 +432,7 @@ pygetxattr(PyObject *self, PyObject *args)
     char *attrname = NULL;
     char *buf = NULL;
     ssize_t nret;
-    size_t nalloc = ESTIMATE_ATTR_SIZE;
+    size_t nalloc = 0;
     PyObject *res;
 
     /* Parse the arguments */
@@ -507,7 +496,7 @@ xattr_get(PyObject *self, PyObject *args, PyObject *keywds)
     char *buf = NULL;
     const char *ns = NULL;
     ssize_t nret;
-    size_t nalloc = ESTIMATE_ATTR_SIZE;
+    size_t nalloc = 0;
     PyObject *res = NULL;
     static char *kwlist[] = {"item", "name", "nofollow", "namespace", NULL};
 
@@ -591,7 +580,7 @@ get_all(PyObject *self, PyObject *args, PyObject *keywds)
     const char *ns = NULL;
     char *buf_list = NULL, *buf_val = NULL;
     const char *s;
-    size_t nalloc = ESTIMATE_ATTR_SIZE;
+    size_t nalloc = 0;
     ssize_t nlist, nval;
     PyObject *mylist;
     target_t tgt;
@@ -621,7 +610,7 @@ get_all(PyObject *self, PyObject *args, PyObject *keywds)
       goto free_buf_list;
     }
 
-    nalloc = ESTIMATE_ATTR_SIZE;
+    nalloc = 0;
     /* Create and insert the attributes as strings in the list */
     for(s = buf_list; s - buf_list < nlist; s += strlen(s) + 1) {
         PyObject *my_tuple;
@@ -645,11 +634,12 @@ get_all(PyObject *self, PyObject *args, PyObject *keywds)
           Py_DECREF(mylist);
           goto free_buf_val;
         }
-        if(PyList_Append(mylist, my_tuple) < 0) {
+        int lappend_ret = PyList_Append(mylist, my_tuple);
+        Py_DECREF(my_tuple);
+        if(lappend_ret < 0) {
             Py_DECREF(mylist);
             goto free_buf_val;
         }
-        Py_DECREF(my_tuple);
     }
 
     /* Successful exit */
@@ -970,7 +960,7 @@ pylistxattr(PyObject *self, PyObject *args)
     char *buf = NULL;
     int nofollow = 0;
     ssize_t nret;
-    size_t nalloc = ESTIMATE_ATTR_SIZE;
+    size_t nalloc = 0;
     PyObject *myarg;
     PyObject *mylist;
     Py_ssize_t nattrs;
@@ -1053,7 +1043,7 @@ xattr_list(PyObject *self, PyObject *args, PyObject *keywds)
     char *buf = NULL;
     int nofollow = 0;
     ssize_t nret;
-    size_t nalloc = ESTIMATE_ATTR_SIZE;
+    size_t nalloc = 0;
     PyObject *myarg;
     PyObject *res;
     const char *ns = NULL;
@@ -1216,6 +1206,10 @@ PyInit_xattr(void)
         goto err_out;
     if((ns_user = PyBytes_FromString("user")) == NULL)
         goto err_out;
+
+    /* Add the new objects to the module */
+    /* TODO: after switching to min 3.10, use the *Ref version, and simplify
+     the error handling. */
     if(PyModule_AddObject(m, "NS_SECURITY", ns_security) < 0)
         goto err_out;
     ns_security = NULL;
@@ -1236,5 +1230,6 @@ PyInit_xattr(void)
     Py_XDECREF(ns_trusted);
     Py_XDECREF(ns_system);
     Py_XDECREF(ns_security);
+    Py_DECREF(m);
     INITERROR;
 }
-- 
2.39.5