Fixup simple autopkgtest when building the binaries
[debian-pyxattr.git] / debian / tests / simple
index 534fc2ffccfbe7aaeb5eb9a2caaaf9aeb12ec378..a68a0b945599a2b81afa89ebbcfd6a1aa93bfaa2 100755 (executable)
@@ -1,5 +1,11 @@
 #!/bin/sh
 
+# switch directory into temp dir to ensure we don't try to use the
+# 'xattr.so' from the source package (if autopkgtest has built the
+# package):
+cd "$ADTTMP/"
+
+# and now simply import the modules:
 python2 -c 'import xattr; print xattr; print xattr.__version__'
 python2-dbg -c 'import xattr; print xattr; print xattr.__version__'
 python3 -c 'import xattr; print(xattr); print(xattr.__version__)'