#!/bin/sh

TESTFILE="$AUTOPKGTEST_TMP/foo"

touch "$TESTFILE"

if setfacl -m u:root:r "$TESTFILE"; then
  echo "Temporary directory '$AUTOPKGTEST_TMP' has ACLs enabled, running tests"
  export TEST_DIR="$AUTOPKGTEST_TMP"
  echo "* testing Python 3"
  # Change to temp directory to ensure any built version of the
  # library is not used.
  cp tests/test_acls.py "$AUTOPKGTEST_TMP"
  cd "$AUTOPKGTEST_TMP"
  # Show the used library path.
  python3 -c 'import posix1e; print(posix1e)'
  python3 -m pytest test_acls.py
else
  echo "Temporary directory '$AUTOPKGTEST_TMP' doesn't have extended attributes enabled"
  echo "Skipping the tests :("
fi