]> git.k1024.org Git - debian-pylibacl.git/blob - debian/patches/python-pylibacl_hurd.patch
Add patch from #534123 to fix Hurd issues
[debian-pylibacl.git] / debian / patches / python-pylibacl_hurd.patch
1 Date: Sun, 21 Jun 2009 16:37:01 -0400
2 From: Barry deFreese <bdefreese@debian.org>
3 To: Debian Bug Tracking System <submit@bugs.debian.org>
4 Subject: Bug#534123: python-pylibacl: FTBFS on Debian GNU/Hurd [Patch]
5 Reply-To: bdefreese@debian.org, 534123@bugs.debian.org
6 Organization: Debian
7 User-Agent: Thunderbird 2.0.0.21 (Windows/20090302)
8
9 Package: python-pylibacl
10 Version: 0.4.0-2
11 Severity: normal
12
13 Hi,
14
15 python-pylibacl currently fails to build on Debian GNU/Hurd because it
16 doesn't recognize GNU as an OS.  Attached is a patch to resolve this.
17
18 Thanks,
19
20 Barry deFreese
21 --- a/setup.py
22 +++ b/setup.py
23 @@ -22,6 +22,10 @@
24          macros.append(("HAVE_LEVEL2", None))
25  elif u_sysname == "Darwin":
26      libs.append("pthread")
27 +elif u_sysname == "GNU":
28 +    macros.append(("HAVE_LINUX", None))
29 +    macros.append(("HAVE_LEVEL2", None))
30 +    libs.append("acl")
31  else:
32      raise ValueError("I don't know your system '%s'."
33                       " Please contact the author" % u_sysname)