]> git.k1024.org Git - debian-pylibacl.git/blob - debian/rules
Fix lintian warnings
[debian-pylibacl.git] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4 #
5 # Modified to make a template file for a multi-binary package with separated
6 # build-arch and build-indep targets  by Bill Allombert 2001
7
8 # Uncomment this to turn on verbose mode.
9 #export DH_VERBOSE=1
10
11 # This has to be exported to make some magic below work.
12 export DH_OPTIONS
13
14 PYVERS := $(shell pyversions -r)
15
16 configure: configure-stamp
17 configure-stamp:
18         dh_testdir
19         touch configure-stamp
20
21
22 #Architecture 
23 build: build-arch build-indep
24
25 build-arch: build-arch-stamp
26 build-arch-stamp: configure-stamp 
27         set -e; for py in $(PYVERS); do \
28             $$py setup.py build; done
29
30         touch build-arch-stamp
31
32 build-indep: build-indep-stamp
33 build-indep-stamp: configure-stamp 
34         touch build-indep-stamp
35
36 clean:
37         dh_testdir
38         dh_testroot
39         rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
40         rm -rf build
41         dh_clean 
42
43 install: build
44         dh_testdir
45         dh_testroot
46         dh_clean -k -s 
47         dh_installdirs -s
48
49         set -e; for py in $(PYVERS); do \
50             $$py setup.py install --root=$(CURDIR)/debian/python-pylibacl; \
51         done
52         rm -rf $(CURDIR)/debian/python-pylibacl/usr/share/doc/pylibacl-0.2.2
53
54 # Build architecture-dependent files here.
55 binary-arch: build install
56         dh_testdir
57         dh_testroot
58         dh_installchangelogs
59         dh_installdocs
60         dh_strip
61         dh_compress
62         dh_fixperms
63         dh_pysupport
64         dh_installdeb
65         dh_shlibdeps
66         dh_gencontrol
67         dh_md5sums
68         dh_builddeb
69
70 # Build architecture independant packages here.
71 binary-indep: build install
72 # Nothing to do
73
74 binary: binary-arch binary-indep
75 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure